connect .familyx with an exe

Oct 10, 2012 at 6:44 PM

hello, nice app there, but one /silly) question: when doubleclicking .familyx files, windows asks me with what to open it. i looked rather thoroughly, but cannot seem to find it?

Oct 12, 2012 at 10:07 PM

chatumao -

It's not clear from your post which file(s) you downloaded. There should be a "FamilyShow.exe" file on your system. If you downloaded the sources and built the solution, then you'll need to find the EXE in your build directory.

The "best"/latest download (from early this year) which contains an executable is:

http://www.codeplex.com/Download?ProjectName=familyshow&DownloadId=364322

Unpack the ZIP onto your system, and you should find "FamilyShow.exe" in the "bin" sub-folder.

If you want an installer, the following patch from 2010 provides one:

http://www.codeplex.com/Download?ProjectName=familyshow&DownloadId=146646

Oct 12, 2012 at 10:21 PM

Thanks for the answer, notonyournelly. I used the installer. In the Startmenu there is the entry for it and a link to run the app. It starts fine and it works nice, but my "problem" is that I cannot open a .familyx file by doubleclicking, the extension is not registered and when I am prompted to choose a default program I do not know where to look. In the properties of the startmenu link it says: "Location - C:\Users\chatumao\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\Microsoft Family.Show". In this location there only are the two links that are from the startmenu...

I guess I can live with that, was just curious because this behavior is not normal, I am accustomed to links that actually refer to an .exe :).

Downloaded the .zip, extracted and tried to run the exe, unfortunately the program "stopped working". 

I will go with what I have, it's working after all and that should be enough. 

Thanks for your time and have a nice weekend.

Oct 13, 2012 at 10:03 PM

chatumao -

I'm sorry you are having difficulties. I will try the installer myself (I haven't used it, nor was I the author) and see if I can find the EXE.

If you wouldn't mind, could you pass along a little more information to help me understand why the ZIP EXE might have "stopped working". Which version of Windows are you running? Can you determine (via "Add/Remove Programs") which version(s) of the .NET runtime you have installed? 

Thank you for your time!

notonyournelly

Oct 13, 2012 at 10:20 PM

Hi again, I guess I can do that.

I'm using win7 home premium.

In programs and features I see only Microsoft .NET Framework 4 Client Profile. I am a little surprised myself, on XP I have at least half a dozens entries for .NET.

But the installed version (3.0.0) runs well on this machine, only that there seems to be no EXE.

Here's the problem details:

Description:  Stopped working
Problem signature: 

Problem Event Name: CLR20r3 

Problem Signature 01: familyshow.exe 

Problem Signature 02: 4.5.0.0 

Problem Signature 03: 4f7b961c 

Problem Signature 04: PresentationFramework 

Problem Signature 05: 3.0.0.0 

Problem Signature 06: 4f350630 

Problem Signature 07: 6263 

Problem Signature 08: e1 

Problem Signature 09: System.Windows.Markup.XamlParse 

OS Version: 6.1.7601.2.1.0.768.3 

Locale ID: 1031

 

That's all for now, hope it helps.

Oct 13, 2012 at 11:49 PM

chatumao -

Thank you for the information! It didn't occur to me that you installed V3.0.

The installer I pointed you at is for "V4.5". During the install on Windows 7, there was a dialog box that asked you where the installation folder should be. For me, it was "C:\Program Files\Vertigo\Family.Show 4\". If I look in that folder, I find "FamilyShow.EXE". I can't seem to easily find a "V3.0" installer...

The installer also seems to have established an association to the .Familyx files; family.Show attempts to execute when I double-click on the sample Windsor.familyx file. But it quickly "stops working". So there may be an issue with double-clicking a familyx file, even with V4.5.

I confirmed that the "newer" ZIP file that I pointed you at does indeed fail if you unpack it. However, I found that if you copy the 'Images' and 'Themes' folders from the installed version to the folder where you unpacked the "newer" version, it should work OK. Except it also "stops working" when I double-click "Windsor.familyx".

So it seems there is a problem with double-clicking, assuming you can get the file association working, or find the EXE. A complete ZIP which runs for the latest version would also be nice to have.

>In programs and features I see only Microsoft .NET Framework 4 Client Profile. I am a little surprised myself, on XP I have at least half a dozens entries for .NET.

I think that's because .NET 3.5 is part of Windows 7. Only .NET 4 is newer.

notonyournelly

Oct 14, 2012 at 12:40 AM

Thanks for your reply, notonyournelly. Glad I could help.

I removed 3.0 and used the installer for 4.5. Switching through various persons now takes slightly more time, but there seem to be a lot of new and useful features. Looks really neat, can't wait to work with it. 

I found the EXE, but as you said, the program "stops working" after doubleclicking any FAMILYX file, so this is not all too helpful. But I guess ther's plenty of time to fix that, it's only a minor issue after all. 

I am a little surprised to see that there's a new version out there, deploying google doesn't lead me to it at all. I assume that the link for the 4.5 installer points to a 64 bit installer, do you happen to have one of these in 32 bit as well? :) Just tried it on XP 32 and it would'nt work.

Apart from that, please allow me one question: In what way are you involved in the project? Simply a user or are you with the team?

Thanks for your time so far and I hope you can help me with the v4.5 32 bit!

Oct 14, 2012 at 9:57 PM

chatumao -

>Apart from that, please allow me one question: In what way are you involved in the project? Simply a user or are you with the team?

"It's complicated." Possibly over-simplifying, Family.Show was a demo project created for Microsoft by Vertigo Software. No "official" activity from Microsoft or Vertigo has happened here for quite some time.

I stumbled over this project earlier this year as both a user and a developer, and have tried to fix some bugs, make a few improvements, and pull together changes from other folks. Alas, without an installer, my version isn't very accessible. I, nor anyone else, can commit changes to this project. I have been in touch with Microsoft and they have been unable to make it possible for anyone to "take over" this project.

Which would explain why you had trouble finding a newer version. It didn't occur to me that the 4.5 installer might be 64-bit only, I'll have to take another look.

There is a "spin off" version of this project, at http://www.chronoplexsoftware.com/ which you might find more usable.

In order to make any further progress extending Family.Show, I believe I'll have to create a "spin off" myself.

notonyournelly

Oct 14, 2012 at 10:52 PM

Thank you, notonyournelly! This is even better! I think I could have used google for ages and still would not have found this... Best piece of genealogy software I've looked at so far. Of course, perfection will never be achieved, but it is decent enough. Good luck with your own projects! Let me know what comes of it!